最新消息:文章中包含代码时,请遵守代码高亮规范!

兼容ie9以下placeholder解决方案

原创文章 user 575浏览 0评论

在开发官网页面时,经常需要兼容ie7,ie8以上版本,同时也会使用到input提示语的使用。这个时候,我们一般会直接就想到使用placeholder,但是ie9一下就不兼容了。

       兼容解决方案:1.下载jquery.placeholder.js(https://www.bootcdn.cn/jquery-placeholder/);

                               2.在body底部添加

<script src="./js/jquery.placeholder.js"></script>
<script>
    $(function () {
        $('input').placeholder({
            customClass: 'my-placeholder'
        })
    });
</script>

       这样就解决了。

转载时请注明出处及相应链接,本文永久地址:/25426.html


pay_weixin
pay_weixin
微信打赏
pay_weixin
支付宝打赏
感谢您对作者Miya的打赏,我们会更加努力!    如果您想成为作者,请点我

发表我的评论
取消评论

表情